Errors while opening on Win10

I get the following errors when trying to run on Win10, DiffPlug v2.3.0 x64.

Error code [126] when trying to load jvm.dll: The specified module could not be found.

Error: failed to load VM runtime library!

No lockfile found at C:\Users\adam.jaslikowski.diffplug.lock
Can’t find a running or installed DiffPlug.

I appreciate any help, thank you!

  1. What is the output of where dp

Reason: dp from DiffPlug 1 does not work with DiffPlug 2, and vice-versa. So the first thing to check is that dp.bat on your path is from DiffPlug 2, and not DiffPlug 1.

  1. Can you launch DiffPlug 2.3.0 by double-clicking DiffPlug.exe? If so, can you then run dp from the console and have it successfully talk to the already-running DiffPlug?

Reason: dp will first look for an already running DiffPlug, and if it doesn’t find one, it will start the most-recently-run instance of DiffPlug. So if the last DiffPlug to run was a DiffPlug 1.x, then you might get an error that looks like this.

  1. Assuming that step 2 worked, can you now close DiffPlug and use dp to launch a fresh DiffPlug?

1). “where dp” = C:\Users\adam.jaslikowski\Downloads\DiffPlug_win_x64_2.3.0\dp.bat
I don’t have and never have had DiffPlug v1

2). Double clicking on DiffPlug.exe causes Windows to give a warning about running programs from unknown sources. I click affirmative to go ahead with running the program. There is no visible response from the program. Running dp.bat from the console provides the same error as before about the lack of a .lock file.

3). N/A, no response from step #2.

I click affirmative to go ahead with running the program. There is no visible response from the program.

So you’re not able to run DiffPlug at all? This is strange, there are many users using 2.3.0 on Windows 10. Thanks very much for reporting, I cannot reproduce on any of our test machines, but I have a hunch for what might be happening on yours…

Here are further debugging steps.

  1. Open cmd.exe
  2. cd C:\Users\adam.jaslikowski\Downloads\DiffPlug_win_x64_2.3.0
  3. DiffPlug.exe -c --console --verbose

Does this run at all? Next, try downloading 2.3.0_wontstartfix, and run those same steps (but change directory to the 2.3.0_wontstartfix).

Running DiffPlug.exe -c --console --verbose as directed provides the following output:

The wontstartfix version is up and working great!

Great! The problem then was a missing MSVC runtime on your system, and the solution in 2.3.0_wonstartfix is just that we bundle our own. We probably should have always bundled it, but we got away with it because our test machines, and all of our customer machines to-date, have had the expected MSVC runtime on the path somewhere (probably from having other developer tools on their path).

We’ll bundle the MSVC runtime from now on, so this will be fixed in 2.3.1 and all future releases. Thanks for the bug report!

Thank you for all your help!

Resolved in 2.3.1. Thanks for reporting!

I just downloaded the win64 version and unzipped it. But I cannot launch the program, nothing happens when I double-click on DiffPlug.exe. Same if I try running it as admin.
Am I missing a step somewhere?



You are not missing a step, there must be a bug! I assume you downloaded the latest version, 2.3.2?

What happens if you try these steps?

Yes, I got the version 2.3.2 today. I get the following:

What version of Windows? 10, or something earlier?

It’s Windows 10, thanks.

@rustcat can you give 2.4.0_wontstartfix2 a try? We can’t reproduce the issue you’re seeing, but we have a hunch. If it works then our hunch is confirmed and the problem is solved.

With 2.4.0_wonstartfix2, the same issue happens, i.e., there is no response. Running it from the command line as before gives the following error:

Just to be sure, I extract the zip-file to a folder in my Downloads folder and run it from there. Thanks.

My Java version is:

Thanks very much for sticking with us while we figure out what’s going on! We’ve made another test, 2.4.0_wontstartfix3. This tries another possible fix, but more importantly we’ve added a lot more debug info.

@rustcat Have you had a chance to try wontstartfix3? There’s something unique happening on your machine, we’d love to get to the bottom of it!